Algoritmos

Pessoal,

O material da disciplina de Algoritmos está disponível. Tutoriais e apostilas estão abaixo, além dos programas (que fiz questão que rodassem de pendrives). Um abraço a todos!

Plano de disciplina de Algoritmo

Apostila de algoritmos

Material de referência do VisualAlg

Material de Lógica com Pascal

Programas que pode ajudar no treinamento da disciplina:

Visualg2 ( programa para compilação de algoritmos em portugues estruturado)

PascalZim (compilador pascal simples de usar)

DevPascal (compilador Pascal para windows)

7 respostas em “Algoritmos

  1. algoritmo “Questão 7 do Livro Pag 194”
    // Função : Escolha de Menu de Opção
    // Autor : Jniltonn82@yahoo.com.br
    // Data : 18/9/2008
    // Seção de Declarações
    var
    Imposto:real
    sal:Inteiro
    Op,clas:caracter
    inicio
    // Seção de Comandos
    Escreval(“—————–ATENÇÃO—————-“)
    Escreval(“—————————————-“)
    Escreval(” Escolha e Digite a Opção Desejada “)
    Escreval(“—————————————-“)
    Escreval(” 1=I m p o s t o “)
    Escreval(” 2=Novo Salario “)
    Escreval(” 3=Classificação “)
    Escreval(“—————————————-“)
    Leia(Op)
    Escreval(“—————————————-“)
    Escreval(” Digite o Salário do Funcionário “)
    Escreval(“—————————————-“)
    Leia(Sal)
    Escreval(“—————————————-“)
    Se(op=”1″)entao
    Se(sal<500)entao
    Imposto850)entao
    Imposto<-(sal*15)/100
    Senao
    Imposto1500)entao
    Sal=750)e(sal<=1500)entao
    Sal<-sal+50
    Senao
    Se(sal<400)entao
    Sal<-Sal+100
    Senao
    Sal<-sal+75
    Fimse
    Fimse
    Fimse
    Escreval(” O Valor do Salario é:”,sal)
    Escreval(“—————————————-“)
    Escreval(” ****Pescione ESC Para Retornar**** “)

    Senao
    Fimse
    Se(op=”3″)entao
    Se(sal<=750)entao
    Clas<-” Mal Remunerado ”
    Senao
    Clas<-” Bem Remunerado ”
    Fimse
    Escreval(” Este Funcionário é:”,Clas)
    Escreval(“—————————————-“)
    Escreval(” ******Pescione ESC Para Retornar****** “)
    Senao
    Fimse
    fimalgoritmo

    Jorge Milk, esse é o algoritmo que Nilton fez na sala de informática. Qualquer problema meu e-mail está ai.fui

  2. Olá Milk, Nilton comentou sobre uma suposta lista de algoritmo que você havia dito ao mesmo na quinta-feira e que iria deixar no grupo cefetesati. Só que não recebi nenhuma notificação do grupo sobre essa lista. Valeu. fui

  3. algoritmo “Q16”
    // Função :caular quanto deve ser pago por um produto.
    // Autor :thycel08@hotmail.com
    // Data : 27/9/2008
    // CEFET – BA, SANTO AMARO
    var
    pe,cp:inteiro
    dec,avt,cart,v2,ac,v3,prc:real
    op:logico
    inicio
    escreval(“digete o preço do produto”)
    leia(pe)
    escreval(“escolha opçao: codigo da condiçao de pagamento”)
    escreval(“cod 1”)
    escreval(“cod 2”)
    escreval(“cod 3”)
    escreval(“cod 4”)
    leia(cp)

    se(cp=1)entao
    escreval(“a vista em dinheiro ou chegue,com 10% de desconto”)
    dec<-pe*10/100
    avt<-pe-dec
    escreval(“preço do produto e:”,avt)
    senao
    se(cp=2)entao
    escreval(“com cartao de credito, com 5% de desconto”)
    dec<-pe*10/100
    cart<-pe-pe*10/100
    escreval(“com cartão preço e:”,cart)
    senao
    se(cp=3)entao
    escreval(“em 2 vezes, preço normal de etiqueta sem juros”)
    v2<-pe/2
    escreval(“preço e 2 vezes e:”,v2)
    senao
    se(cp=4)entao
    escreval(“em 3 vezes, preço de etiqueta com acrecimo de 10%”)
    ac<-pe*10/100
    prc<-pe+ac
    v3<-prc/3
    escreval(“preço e:”,prc)
    escreval(“3 vezes e:”,v3)
    fimse
    fimse
    fimse
    fimse
    fimalgoritmo

  4. Program NumerosImparesAcumuladoNumVetor;
    var
    vetor:array[1..5]of integer;
    num,i:integer;
    Begin
    for i:= 1 to 5 do
    begin
    writeln(‘Digite numero ‘,i);
    readln(num);
    while (num mod 2 1 ) do
    begin
    writeln(‘Redigite numero ‘,i);
    read(num);
    end;
    vetor[i]:=num;
    end;
    writeln(‘Numeros IMPARES Acumulado num Vetor’);
    for i:= 1 to 5 do
    begin
    writeln(vetor[i]);
    end;
    end.

  5. Program Q2;
    Var
    notas:array[1..5] of integer;
    i:integer;
    maior:real;
    Begin
    maior:=0;
    for i:= 1 to 5 do
    begin
    writeln(‘Digite Nota ‘,i);
    readln(notas[i]);
    while (notas[i] 10 ) do
    begin
    writeln(‘Redigite Nota ‘,i);
    readln(notas[i]);
    end;
    if(notas[i]> maior)then
    begin
    maior:=notas[i];
    end;
    end;
    writeln(‘Esta é a Maior Nota do Aluno: ‘,maior:2:2);
    End.

  6. Program apartamento;
    var
    nomes:array[1..5] of string;
    nome:string;
    achou:boolean;
    apto,i:integer;
    Begin
    achou:=false;
    for i := 1 to 5 do
    begin
    writeln(‘Coloque ‘,i,’o morador no Apartamento ‘,i);
    readln(nomes[i]);
    end;
    writeln(‘Lista dos Moradore do Predio ATLANTA.’);
    writeln(‘Digite nome do morador para saber qual Apartamento ele mora’);
    readln(nome);
    for i := 1 to 5 do
    begin
    if(nome=nomes[i])then
    begin
    achou:=true;
    apto:=i;
    end;
    end;
    if(achou=true)then
    writeln(‘O morador que voce procura mora no apartamento ‘,apto)
    else
    writeln(‘O morador que voce procura nao foi Encontrado’);

    writeln(‘Estes São os Nomes digitados’);
    for i := 1 to 5 do
    begin
    writeln(nomes[i]);
    end;

    End.

  7. Program q1lista ;
    var
    n:Array[1..50] of integer;
    i:integer;

    Begin
    For I:= 1 to 50 do
    Begin
    writeln(‘Digite um numero ‘,i);
    readln(n[I]);
    end;
    writeln(‘Estes São os Números Digitados’);
    For I:= 50 downto 1 do
    Begin
    writeln(n[I]);
    end;
    End.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s

Este site utiliza o Akismet para reduzir spam. Saiba como seus dados em comentários são processados.